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Vega gateways support the delivery of Radius Accounting records to 
Radius Servers in order to log call detail records for billing or 
management statistics. 

Vega Radius Accounting records conform to the standards, and so 
are compatible with many Radius Servers.  This document describes 
the installation and configuration of one such standard Radius server 
– TeleCount from I.S. Associates Inc. 
 
 
Pre-requisites 

TeleCount server Version 5.01.00.069 or greater 
TeleCount AAA Server Version 2.0.0.0 or greater 
SQL server software (e.g. SQL Server Desktop) 
 
 
Install Telecount 

Start by installing the TeleCount software by running tcsetup.exe (or tcsetupbeta.exe) and follow 
the on-screen instructions (see the supplied documentation “gettingstarted.pdf” for further 
details). 
 
When asked, do not tick the “Load DCU on system start-up” check box. 
 
Run telecount for the first time 

Start up TeleCount (not the TeleCount Management Console). 
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When asked, the internet access page can be left blank: 
 

 
 
Next the Licence Wizard starts up; complete as required. 
 
The New Database Wizard then starts automatically. 
 

 
 
Keep database Description and Database Type set to their default values 
 
If you have an SQL database server already available skip this next part and continue at the 
section “New Database Wizard 2” below. 
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If you do not already have an SQL database server and plan to install SQL desktop, select the 
New Database Server button 
 

 
 
When asked, un-tick the “CD-Rom” check box and tick the “Other” check box; browse to the SQL 
desktop install files [SQLServerDesktop.exe] 
 
Select Open, then click Next > 
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Give the SQL database server an instance name and note it down, e.g.: 
 

Instance Name = SQLFORTELECOUNT 
 
Leave the “Install Under Program Files folder” check box ticked 
 
Don’t believe the “Time Remaining” value – the PC may take a lot longer to do the install. 
 
After loading the SQL server, reboot the PC and start up TeleCount again. 
 
 
New Database Wizard (2): 
 

 
 
Select the just installed, or previously available instance of the server from the drop down list (or 
using the browse function). 
 
Set up your own password for the server, by setting the User Name = sa and leaving the 
password field blank. 
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Ticking the “Share this user name and password” check box allows other installations of 
TeleCount to access the server without having to explicitly enter the SQL server username and 
password on each PC. 
 
Click Next > and the change password screen will appear – set up your own password and note 
it down e.g.: 

Password = telecount 
 

When requested to select a database, select the New Database button to create a new database 
on the server just identified. 
 
Note down the Database Name you give, e.g.: 
 

Database Name = test_telecount_SQL_db 
 
Click Next > 
 
Note down the username and password you specify for this database, e.g.: 
 

User Name = admin 
Password = vega 

 
Click Finish on the New Database Wizard 
 
The TeleCount login wizard starts 
 
Select “Database” and click Next > then enter the Operator Name and Password (these are the 
values just configured above, e.g.User Name = admin and Password = vega). 
 
Choose billing type = postpaid 
 
Install and configure services 

- take defaults and also tick the Process Radius Feed entry 
- Select each item in turn and click the Configure button – work through each of the 

configurations options.  Accept defaults, except set up Process Radius Feed with 2 
sessions. 

- … expect an error message on one of the configurations 
 
Click Next > 
 
… expect and OK several error messages as the services are installed 
 
Click Finish 
 
 
Start up Telecount and log in 
 
Set up DB Description, e.g “Telecount Billing Database” 
 
Un-tick the “hierarchical structure” check box 
 
Set Level 1 = Company, Region, Division, Department, CostCntr 
Leave the other “Level” fields blank 
 
Click Next > 
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Leave Hospitality set to No (this will be configured later on) 
Choose the appropriate currency. 
 
In the Tariff Update Wizard 
 
Select an appropriate number plan 
Select an appropriate tariff update file – provided by I. S. Associates 
 
Leave the configuration as “ignore carriers”, “ignore locations” and “ignore Intl locations” 
Click Next >, click Finish 
 
In the Switch Wizard 
Set: 

Switch Type = “Voice over IP/FR” 
Switch Name = “Cisco Radius Accounting Attribute Dump (VOIP)” 
Switch ID = 1 

 

 
 
Complete other information for the wizard 
 
Set Capture method = Direct file 
 
Click Finish 
 
 
 
 
Install TeleCount AAA Server 

Follow I. S. Associates’ documentation for installing; this includes downloading and installing the 
Microsoft .NET Framework, Microsoft Data Access Components (MDAC) 2.7 as well as the two 
files TCAAASetup.exe and msvcp60.dll 
 
Once installed, double click the Telecount AAA Server icon on the desktop to start the 
application. 
 
From the Tools menu, select register and then enter the registration code, or demo version code. 
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From the Tools menu select “Install Services” (this installs the Radius Services). 
 
In the AAA Server Properties section, set up the Switch ID to the same value that was specified in 
the Switch Wizard, e.g. 1 
 

 
 
Also set up the default GMT offset. 
 
In the “Clients” section, set up the IP address, secret and description of the Vega gateway(s) that 
will be supplying Radius records by right clicking in the right hand panel and selecting 
Add Client. 
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Configure all the SQL database information: 
 

 
 
To find the Server Name, find the SQL Server Service Manager icon in the system tray (a grey 
computer-like icon with a green arrow).  Place the cursor over this icon and it will display 
\\<server-name>\<instance-name>.  Enter <server-name>\<instance-name> as the Server Name. 
 
If only a single SQL database is to be used (no secondary database) then configure the 
secondary database details to be exactly the same as the primary database details: 
 
Configure text logging: 
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In the Authorization section set Enabled = NO: 
 

 
 
If the application says “Start Services“ rather than “Stop Services”, click “Start Services” to start 
them: 
 

 
 
 
 
 
Configure TeleCount Management Console 

Either find the TeleCount Management Console in the system tray, or select 
Start>Programs>TeleCount>TeleCount Management Console 
 

 
 
Select File>Login and use the admin / vega Operator Name / Password. 
 
In the left panel, select “Database Jobs”, then select Action>Install Job. 
Select the “Process Radius Feed” option 
Continue until the process “Process Radius Feed” is seen in the Database Jobs panel.  If it is not 
running, then select it and click the green arrow in the command bar to start the job. 
 

Vega and TeleCount Radius Server interoperation - Version 0.5  6 January 2004  
For use with Vega firmware R5.1 and above Page 9 of 13 © 2003 - 2004 VegaStream Ltd. 



 
 
 
Configure TeleCount 

If it is not already running, Start Telecount by selecting Start>Programs>TeleCount>TeleCount 
 
Login using the admin / vega Operator Name / Password. 
 
Select File > Billing > AAA options and then the “accounting” tab.  Select Vega Gateway from the 
pull down list as the Primary Switch ID 
 
Click OK 
 
 
 
Vega Configuration 

Radius: 
With the retry timers (T1 and T2) set to their default values, the Vega gateway starts sending out 
repeat messages before TeleCount has had time to respond to the original messages.  This 
produces unnecessary loading on the TeleCount system. 
 
In order to reduce the loading on TeleCount set 

 T1 Retry Timer to 3000 (from default 500) and 
 T2 Retry Timer to 6000 (from default 4000)  

 
Date and Time: 
When logging billing records it is important that the Vega presents the correct date and time in the 
Radius records.  To ensure that the Vega keeps accurate time it should be configured to collect 
its date and time from an NTP server at power up and update it regularly – e.g. once per day.  
(See the Vega Primer for details on configuring NTP).  
 
 
 
Check that calls are correctly logged 

Once some test calls have been made, in the Telecount application select “Open Activity Table”: 
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The database(s) of calls can be found by selecting “Voice over IP/FR”: 
 

 
 
Double click an activity record database. 
In the wizard that starts up, select “All matching records” and make sure that the date range fully 
includes the dates of the calls that have been made.  Keep selecting Next > / Finish until the 
records are displayed 
 
 
 
 
Trouble shooting 

To see radius records being received and processed, look at the TeleCount Management 
Console’s System Status > Process Status.  Processed and Total Counts increase as radius 
records are received and processed (Accounting on / off and Start / Stop records). 
 
If a more detailed view of the received radius records is required, start up the TeleCount AAA 
Server and select Tools > Launch debug.  Re-start the services, and as radius records are 
received they will be displayed in text format in the debug window. 
 
When a Vega is powered up, it should send a single Accounting on message and then the 
TeleCount AAA Server should acknowledge it and so stop the Vega re-sending the message.  If 
the Accounting on message is being repeatedly sent, it is likely that the Telecount AAA Server is 
not acknowledging it, and that is likely to be because the server cannot access the SQL 
database.  Check for typos in the database name and passwords in the AAA Server 
configuration. 
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Call-shop logging 

For call-shop logging, the “Hospitality” features of the TeleCount software allow per-phone billing. 
 
When a customer arrives to use the call-shop facilities, the operator does a “Guest Check In” 
against a specific phone and shows the customer to that phone.  The customer then makes all 
the calls they need to.  When they have finished the operator performs a “Guest Check Out” and 
prints a bill for all the calls made between check in and check out on that phone. 
 
To configure this functionality, perform the following steps: 
 
Create directory entries within TeleCount (the Directory ID for each of these entries will 
be the room numbers) 

1) Open the Directory Table in TeleCount (File>Directory Management>Directory Table) 
2) The Directory Table will open.  Click the new record button; 

 
 

a text box will appear asking for a Directory ID. 
Set this Directory ID to be the room number / name (for example room 514 could have a 
directory id “514” or “Room 514”).  Click OK 

3) Click on the "Association" tab of the directory entry.  In the left-pane you will see "Phone 
Numbers”. 

4) Click on "Phone Number" and in the right-pane right-click and choose "Add".  A New 
Phone Number window will appear. 

5) Select the "Add One Phone Number" radio button and enter the phone number into the 
field (5833514 for example) – This must be the same number that the Vega has been 
configured to provide as its caller ID.  Click OK. 

6) Select save changes 

 
 
 
Now anytime someone makes a call from phone number 5833514, the record will be associated 
with room 514. 
 
Repeat for other rooms / phone numbers. 
 
 
To check people into rooms, perform the following steps: 
 

1) Choose File>Hospitality>Guest Check In or press the F11 key on the keyboard; a check-
in window will appear. 

2) Enter the directory id (room number / name, e.g “514” or “Room 514”) that this person will 
be using.  Click OK  

3) Now enter the person's name details and Click Check In then Click OK 
 
Now any traffic associated with that room will be billed to this customer. 
 
 
To check people out of rooms, perform the following steps: 
 

1) Choose File>Hospitality>Guest Check Out or press the F12 key on the keyboard; a 
check-out window will appear. 

2) Enter the directory id (room number / name, e.g “514” or “Room 514”) that this person 
has used.  Click OK  
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3) You will see the name information you entered upon check in (also check in and check 
out time details).  Click Check Out 

4) A new window will appear.  Choose the activity type “Voice Over IP/FR”; check any 
option boxes that are applicable. 

5) Click the "Print" button to print their report to hand to the customer and show them the 
calls they placed and charge them. 

  
 
 
 
Contact details for I.S. Associates Inc 

www.isassoc.com 
 
1260 Rankin 
Suite G 
Troy 
MI 48083 
USA  
 
Tel: +1 800 583 3440 
Tel: +1 248 583 3440 
Fax: +1 248 583 6221 
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VegaStream Inc. 
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