NetBorder Express 2.0

@ SANGOMA Tone Detection and Generation

Configuration Guide

Overview

This guide will show you how to configure tones for your NetBorder Express gateway. There is a great variety of tones
from country to country and NetBorder Express needs to be configured accordingly.

You will find that this guide has several pages but this does not mean it is a highly complex process. Rather, we have
included several screenshots to guide you through the process.

There are two broad functions in the gateway regarding tones in NetBorder Express: Tone Detection and Tone
Generation.

For Tone Detection, the NetBorder Express Gateway uses tone definition files. These are in XML form. All you need to
adjust the tone definitions is to edit the file with a text editor or within the NetBorder Express Gateway Manager Web
GULI. This guide will provide you with detailed examples using the NetBorder Express Gateway Manager Web GUI. To
illustrate further, we will use Germany settings, as an example.

For Tone Generation, the NetBorder Express Gateway plays sound files in a RAW format. What you need to do to adjust
Tone Generation for NetBorder Express is to use an Audio Editor application to generate the RAW files. This guide will
provide you with ample details using screenshots from free applications.

Version 2.x of NetBorder Express is pre-configured for North American tone sets. So you do not need to perform these
steps if your installation is within North America (USA and Canada).

For DTMF tones, NetBorder Express default installation is universal, so you do not have to adjust anything.

Tools and pre-Requisites

1. Pre-Installed version of NetBorder Express

2. Access to a Tone Definitions database. Here are some useful links:
e http://www.itu.int/dms pub/itu-t/oth/02/06/T02060000040002PDFE.pdf
e http://www.3amsystems.com/wireline/tone-search.htm

3. Preinstalled Audio Editors. Here you will need 2 applications: Audacity and NCH Audio Switch. These are free
applications.

e To create WAV files, Audacity is required. You can get it here:

http://audacity.sourceforge.net/download/. At the time of this writing, version 1.2.6 was used.

e NCH Audio Switch is required to convert the WAV files into RAW format. You can get it here:

http://www.nch.com.au/switch/ . At the time of this writing, version 2.01 was used.

Let’s get started!
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@ SANGOMA

Configuring Tone Detection

This step requires the editing of the tone definition XML files. Here we will use Germany as an example.

1. Launch the NetBorder Gateway Manager Utility (here on the localhost:7783) and point it to the File Browser sub
menu and then to the tone-db subfolder. Scroll down to Germany and click once on the file name. The XML file
is now ready to be edited.

’
@ Gateway Manager - Mozilla Firefox [0 |
File Edit View History Bookmarks Tools Help
EXPRESS volP Gateway e
Status and Controls Configuration fluick Setup File Browser Help
=3 root
= [_] bin
[ [_7] config
B [ data File: /root/tone-db/germany.xml
] loge <l version="1.0" encoding="ytf-8" 7> -
name="GERMANY" version="1.0"=> F
=3 tone-db =
£ argentina.xml <l *** IMPORTANT *** This tone set does not contain the true tone
& australia.xml definition for the current country. The user shall edit this file =
- ) to specific the rigth tone definition. —=
4 austria.xml
£ bahrain.xml || <!~ Tone definitions
£/ belgium.xml b =
& ; A tone is defined as sequence of signals where each signal (si) last
4 brazil.xml - = !
- ’ for a specified duration in second (di).
&4 bulgaria.xml
£ canada.xml Example A:
4| chile.xml
D Chinari toneA = s1/d1, s2/d2, s2/d3
£ columbia.xml In this example tone is defined by a signal 51 that wil last for a
)| croatia.xml duration d1, followed by a signal s2 that will last for duration d2,
@) cyrpus.xmi folowed by a signal 53 that will fast for duration d3.
) czech.xml The signal could be:
| denmark xml - off: no signal
S - f1: a single frequency
| ecuador.xml
= il - f1+f2: juxtaposition of two frequencies f1 and f2 without modulation.
#| egypt.xm - f1+f2+f3: juxtaposition of tree frequencies f1, f2 and f3 without
€| elsalvador.xml modulation.
&) focxml - f1xf2: f1 is modulated by f2 *** NOT SUPPORTED IN THIS VERSION ***
) Where all fi are specified in Hz. e
#| france.xml | &
4 germany.xml {5 Save Changes ] [ Clear Changas
Gateway SiamrEr=t Configuration Synched @
Done
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@ SANGOMA

You need first to datafill tone definitions and then assign them to Tone Detection Rules.

You need at this point the tone definitions for Germany. These are:

e Busy Tone: 425 Hz for 0.48 sec, OFF for 0.48 sec, repeat

e Reorder Tone / Congestion Tone: 425 Hz for 0.24 sec, OFF for 0.24 sec, repeat

e Dial Tone: 425 Hz Continuous

e Ringing Tone: 425 Hz for 1.0 sec, OFF for 4.0 sec, repeat

e Call Waiting: 425 Hz for 0.2 sec, OFF for 0.2 sec, 425 Hz for 0.2 sec, OFF for 5.0 sec, repeat

e SIT Tone: 950 Hz for 0.33 sec, 1400 Hz for 0.33 sec, 1800 Hz for 0.33 sec, OFF for 1.0 sec, repeat

Here is the germany.xml file updated with the German specifications:

@ Gateway Manager - Mozilla Firefox
File Edit Yiew History Bookmarks Tools Help

(& o (1

NetBorder’
EXPRESS VolP Gateway

Status and Controls

http://localhost: 7783/
@® SANGOM

Configuration Quick Setup File Browser Help

€4 argentina.xml
@| australia.xml The user may create as many tone he needs in this section. The name
of the tone is not important, as long as the name is unique within
tones context of this tone set. The name is used as a unique key to
identify a given tone definition. The tone detection and generation
rule are referepCinges=Te Elly s

| austria xml
4| bahrain.xml

£ belgium.xml
€| brazil xml

4| bulgaria.xml
4| canada.xml

<tones defaultFrequencyTolerance="+/-50" defauttDuration Tolerance="+/-35%">
<tone name="busy">425/0.48, off/0.48 periodic</tone>

@ chie.xml <tone name="reorder">425/0.24, off/0.24 periodic</tone>
@) chinasal <tone name "=425/2.0</tone>
<tone name="ringing">425/1.0, off/4.0 periodic</tone>
) columbia.xml <tone name="cal_waiting">425/0.2, off/0.2, 425/0.2, off/5.0 periodic</tone>

<tone name="sit">950/0.33, 1400/0.33, 1800/0.33, off/1.0</tone>
< /tones=

4| croatia. xml
£ cyrpus xml

| czech.xml sqg detection rules|

£ denmark.xml
This section tells which tone detnmg Te ror each type of
tone required by the gateway. For each type of tones, the user may
specify one or more tone definiions. Each tone definition shall be
delimited by the pipe ('|') caracter. For example: If in a given
country the application has to recognize 3 types of busy tone

(busyl, busy2 and busy3) the user shall enter the busy detection
rule as follow: <busy=busyl |busy2|busy3</busy>

| ecuador xml
& egyptxml

£ elsalvador xml
6| foc.xml

€| finland.xml

4| france.xml

) germany.xml

[ Save Changes ] [ Clear Changes

Gateway Stahis: ctonned

=<3 root + This section of the webUl allows you to read and edit configuration and logging files. Grayed out file name in the tree
& £ bin means a read only files. It is possible to download files by right-clicking on a file in the tree panel.
&[] config
S data File: /root/tone-db/germany.xml
@] gs Example C:
= Jtene-db E periodic_toneC = s1/d1, s2/d2, s2/d2 periodic

A

m

m

Confinuration Sunched
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@ SANGOMA

3. Next Step is to edit the Detection Rules in the same file (scroll down). Here is the updated file for our Germany
example. Do not forget to click on the Save Changes button!

@ Gateway Manager - Mozilla Firefox
File Edit View History Bookmarks Tools Help

& -c & (O

| Gateway Manager =

NetBorder®

Status and Controls

Gl 210

Configuration Quick Setup

L IE

#| cyrpus.xml

®

czech.xml

z

i| denmark. xml

z

¥ ecuador.xml

2

§| egyptxml
| elsalvador.xml

#4| jordan.xml
4| kazakhstan.xml

=

&) kuwait xml

€ latvia.xml

4| lebanon xml

| luxembourg.xml
| macao.xml

Gateway Status: stopped

EXPRESS VolP Gateway

<reorder=reorder</reorder=
<dial>dial</dial=|
<ringing=ringing=</ringing=
<sit =sit</sit>
</detection_rules=

Tnne nanaratinn r

http://localhost:7783/

D 3am Systems - World PSTN Tone Du.,

File Browser | Help

@ SANGOMA

File: /root/tone-db/germany.xml

<tones defaultFrequencyTolerance="+/-50" defaultDurationTolerance="+/-35%">
<tone name="busy">=425/0.48, off/0.48 periodic</tone>

eorder"=425/0.24, off/0.24 periodic</tone=
ial"=425/1.0</tone>

tf fec.xml inging"=425/1.0, off/4.0 periodic</tone>

| finland xml |_waiting">425/0.2, off/0.2, 425/0.2, off/5.0 periodic</tone>
| france xml <tone name="sit">950/0.33, 1400/0.33, 1800/0.33, off/1.0</tone>
£ germany.xml </tones>

@ joresce xmi £l <l- Tone detection rules

€ guam.xml

€| hongkong.xml This section tels which tone definition(s) to use for each type of

@] hungary xmi tone required by the gateway. For each type of tones, the user may

3| fuingary specify one or more tone definitions. Each tone definidion shall be

| iceland.xml delimited by the pipe ('|') caracter. For example: If in a given

| india.xml country the application has to recognize 3 types of busy tone

@| indonesia.xmi (busyl, busy2 and busy3) the user shal enter the busy detection

= i rule as follow: <busy=busy1|busy2|busy3</busy=

6 ireland xml

€4 israel xml

) taly.xml <detection_rules>

@) japan xmi <busy=busy</busy=

Save Changes ] [ Clear Changes

+ [This section of the webUI allows you to read and edit configuration and logging files. Grayed out file name in the tree
means a read only files. It is possible to download files by right-clicking on a file in the tree panel.

m

Configuration Qut of Synch &

»

m
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Configuring Tone Generation

@ SANGOMA

For Tone Generation, you will have to generate 8 RAW files with a sound editor. These files will have to be named in a
specific way and copied in the proper folder, as shown in the picture below. It looks like they have a funny naming
convention, but they really refer to tone IDs defined by the IETF RFC2833 (RTP Payload for DTMF Digits, Telephony
Tones and Telephony Signals). A-Law and u-Law refer to different companding algorithms. In general terms, u-law is in
use in North America and A-law is used in the rest of the world.

tone_70_alaw = Ringing Tone

O[5 « Gotrwsy » tones

tone_70_ulaw = Ringing Tone

- [ ¢ |[ search

File Edit View Tools Help

&y Organize ~

tone_72_alaw = Busy Tone

Favorite Links

Folders

tone_72_ulaw = Busy Tone

4 | Netharder
4 | Express
4| Gateway

tone_73_alaw = Congestion Tone

b 4 bin
| config
I L data

tone_73_ulaw = Congestion Tone

I Ju doc
L drivers

I 1 logs

tone_74 alaw = Special Information Tone

& |1 oamWebServer
[+ |1 Pythen-2.5
. tone-db

tone_74_alaw = Special Information Tone

| tones
(3] Notibdﬂ-
o ! OpenOffice.org3

MName

@ Bum

Type

tone 12 alaw RAW File
tone 12_ulaw RAW File
tone_13_alaw RAW File

8| tone_13_ulaw RAW File
tone_14_alaw RAW File
tone_14_ulaw RAW File
\ﬂtone_lS_alaw RAW File
8| tone_15_ulaw RAW File
tone_70_alaw RAW File
tone 70_ulaw RAW File

8| tone_72_alaw RAW File
tone_72_ulaw RAW File
tone 73_alaw RAW File

| tone 73_ulaw RAW File
8| tone_74_alaw RAW File

| tone 74_ulaw RAW File

4 m

The RAW files that are pre-installed correspond to North American tones. So for our Germany example, we will need to
create new ones. For this, we will use Audacity.

1. Launch the Audacity application. It should look as follows:

(- Audacity
File Edit View Project Generate Effect Analyze Help

7

*

Nes s e e

[ Tl

[R] [ R[

1:)|2|48-42 36 -30 -24 18 12 6 0 lslil 48 42 36 -30 24 -18 12 6 |

-1.0

B o] s[aLlA]
00 1.0 2.0

3.0

4]

4.0 5.0 6.0

7.0

8.0

9.0

Project rate: 8000 |Cursﬂr: 0:00.000000 min:sec [Snap-To Off]
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@ SANGOMA

2. We now need to edit preferences of the software. Go to the Edit menu and select Preferences...

Select the Quality tab. Set Sample Rate at 8000 Hz and the Default Sample Format at 16 bit as follows:

) Audacity [=EIE=]

File Edit View Project Generate Effect Analyze Help

=
1P

“) » —
padb _J _) Audio O Qualty | Fie Fommts | Spectrograms | Directories | Interface | Keyboard | Mouse | 18 42 36 -30 24 18 12 6 |

B @ 111LF|HJI—U1I‘ bt Defaut Sample Rate: [EXIDLE ~| [E000

10 ()

Defaut Sample Fomat: [1668 <
Realtime sample rate converter: |Fast Sinc Interpolation =
High-quality sample rate converter: | High-qualiy Sinc Interpolation =
Realime diher: [Nome  +

High-qualtty dither: | None -

HES

o

Project rate: 3000 | [Cursor: 0:00.000000 min:sec [Snap-Ta Off] P
A

Under the File Formats tab, set the Uncompressed Export Format to WAV (Microsoft 16 bit PCM) as follows:

) Audacity [EEIE]

File Edit View Project Generste Effect Analyze Help
[T,
Hpel * /| Ao 10| Qualty Fie Fommats | Spectrograms | Directores | Interface | Keyboard | Mouse | 148 42 36 -30 24 18 12 6 |

B[] o]
(]

—
Healh ] When importing audia files into ty
10 € Wake a copy of the file before editing (safer)
g & Read direclly from the origin fe Faster)

~Ur Export Format

icrosoft 16 bit PCM)

WAV {Microsof). Signed 16 bt PCM

0GG Bxport Setup
’7065 Qualty: [5 0 ; 10 ‘

~MP3 Export Setup
MP3 Library Version: - MP3 exporting plugin not found Find Library

Bit Rate: 128 x

Projectrate: 3000 | [Cursor: 0:00.000000 min:sec [Snap-To Off] P
A
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@ SANGOMA

Under the Interface tab, unselect the Edit and Mixer Toolbar options as follows:

& Audacity =

File Edit View Project Generate Effect Analyze Help

W ] ]
o[k _) g 45 36 24 12 61
T g Audo 0 | Qualiy | Fle Formats | Spectrograms | Directories  Intefface | Keyboard | Mouse | —
-1.0 o0 [¥ Autoscroll while playing

I~ Aways allow pausing

¥ Update spectrogram while playmm
™ Enable Edit Toolbar
I~ Enable Mixer Toolbar
[V Enable Meter Toobar
Sbnducac, SETESt window
[V Enable dragging of left and right selection edges
I™ Enable ergonomic onder of Audio /0 buttons.

Language: [Englsh -

Minimum of dB mode display rang

@ -36 dB (shallow range for high-ampltude sdiing)
48 dB (PCM range of 8 bit samples)

56 dE (PCM range of 16 bit samples)

120 dB (spproimate limit of human hearing)
145 dB (PCM range of 24 bit samples)

cocn

Ll

Project rate: 8000 | [Cursor: 0:00.000000 min:sec [Snap-To 0F]

3. We are now ready to start editing a sound file. Let’s start with the Germany Busy Tone, which is defined as
425 Hz for 0.48 sec, OFF for 0.48 sec.

Go to Project > New Audio Track

Project Generate Effect Analyze Help

L] TL
R| [ R

W nm) m) ™
_) tz .J _) _) _) Sy 45 363024 12 60 S 45 363024 A2 5
oo Play (Shift for loop-play) £ oL 2L G oy By 9:".

4]

|Pray (shift for loop-play)

Project rate: 8000 |cursor: 0:00.000000 minsec [Snap-To 0ff]

© 2009 Sangoma Technologies NetBorder Express 2.0 Tone Configuration Guide Page 7
Ver. 1.0



@ SANGOMA

4. Go to Generate > Tone. Enter the frequency and duration in seconds (here 425Hz for 0.48 sec.) and click Generate

Tone.
& Audacity EEE]
File Edit View Project Generate Effect Analyze Help
[X0 —t B
B [ 3 ® n Tone Generator
}3|“' k ) ,/ j j ,/ 24 12 6 0 f’\il 45 .36 -30 -24 12 6
1.0 1.0 2.0 Waveom: [Sme <] 6.0 7.0 8.0

4]

9.0
g

Frequency / Hz [425
Ampliude @-1) [1.00

Length fpeconds) [28
coes

Project rate: 8000 |cursor: 0:00.000000 min'sec [Snap-To Of] p
A

) Audacity [F=H|EER|Ex
File Edit View Project Generate FEffect Analyze Help .
] I = g b [ 2L IL}
5 = R
g W) ) ®) N | ]

p|H k / ,/ / j j j’ Wy 45 363024 12 60 S 45 363024 12 6 (

-0. 0.

4

Project rate: 8000 |Selecbun 0:00.000000 - 0:00.4280000 (0:00.430000 min:sec) [Snap-To Off] 4
v

5. Go to Edit > Move Cursor > to Track End to position you cursor at the end of the track.
6. Go to Generate > Silence. Insert a silence for 0.48 sec.

File Edit View Project Generate Effect Analyze

—
.
’ " W ”' ‘ mumuu|||m||m|m'um'|ummuummlImm'u“" " 0 " ’" { H m

Projectrate: 8000 | [Cursor: 0:00.430000 min'sec [Snap-To OF] v

— —

Help

mj lbj .j |!} -,/

E
] ¥ g
j H “)lil 45 36 -30 -24 A2 6 0 }lil 45 .36 -30 -24

12 6 (

0.00 0.10 0.20

ﬁ "1‘ ]“"\'1 [y W\” VT “ ‘r T

Lo
-1 u \‘“"\ |h| |“| \||“‘\ |h| |||| ||“H\ ‘“‘ |‘| |||H‘I ”““ ‘

0.30
il

Click and drag to select audio

Project rate: 8000 | setection: 0:00.480000 - 0:00.960000 (0:00.430000 min:sec) [Snap-To Off]
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@ SANGOMA

7. Repeat the process so that you have at least 2 cycles. You track should look now as follows:

p 040 0.50 0.60 0.7

3 Audacity E=3(EcE >3
File Edit View Project Generate Effect Analyze Help

1l 1 TR

: W) >) @) n) m)w) | "]

gp|H * S a4 363024 12 60 S 45 363024 A2 6 (
20.30 -0.2

0.80 0.90 1.00 1.10 1.20 1.30 1.40 1.50 1.60 1.70 1.80

Click and drag to select audio

Project rate: 8000 |Cursur: 0:00.327865 min:sec [Snap-To Off]

8. Now you can listen to the track for verification and to check the volume. Hold the shift key and click on the play
button for loopback playing. It sounds like a Busy Tone!

) Audacity
File Edit View Project Generate Effect Analyze Help

= e

o=

BEEIE:
-0.30 -0.20 -0,

Sy 45

-36 -30 -24 12 6 0 ,@E 45 36 -30 -24

Audio Track ¥

|Play (shift for loop-play)

Project rate: 8000 |Cursur: 0:00.327865 min:sec [Snap-To Off]

9. However, the volume is too loud (green bars on the meter toolbar).

As a rule of thumb, you should stay below -12 dB.

While the track is playing in loopback, slide the volume to the left to lower the volume.

3 hudacity
File Edit View Project Generate Effect Analyze Help

E=8|Ee8 55

JTT={s
BEEIE:

7
L)

) il T)

Z|L
ZIR

e 4

[ R
42 6 0 S 45 36-30 24

-36 -30 -24

Drag the label vertically to change the order of the tracks.

Project rate: 8000 |Cursur: 0:00.327865 min:sec [Snap-To Off]
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@ SANGOMA

10. Now we are ready to save our file. Go to File > Export as WAV and save your file

63 Audacity EEE]
File Edit View Proje| € Save WAV (Microsoft) File As: B2
Tr=¢ » Tones ~ [ 44 [ Searcn 2|
: = 1
D ook 45 36-30 24 12 6 (
-0.30 -0.20 -0. = 1.60 1.70 1.80 1.90
Favorite Links Namé Adtists Album #
E| Dam— @Germany_ilT_Tone
@] UK_Ringing_Tone
More »
Folders N
“““ bﬁ?fd\ckey o
“““ [ 4 Public
&~ /8 Computer
& ¥ Netwark
» [& Centrel Panel
£ Recycle Bin
> Ly TDM_Gateway_User_Guide
| Tones
File name: Germany_Busy_Tone
Save as type: | WAV (Microsoft) files (*.wav)
= Hide Folders ave Cancel
Project rate: 8000 | [cd P
v

11. Repeat this process for all your tones. Once you have the WAV files for all your tones, you are ready to produce the

RAW files.

12. We are now ready to generate the RAW files using NCH Audio Converter.

13. Open NCH Audio Converter.

B Switch Sound File Converter

s [E=8Eo Fx3)
File Convert Edit Help

AddFile(s) AddFolder FRernove  Rernowe Al Options Play Stop Conwert Upgrade  ToolBox Help
List of files to convert Format Size Conta... Extended Information

Add Files to Convert into this list by dicking the "Add Files™ button or pressing Alt+A on your keyboard.

Output folder  ¢:\Users\fdickey'Desktop'Tones

s samat |

Switch Sound File Converter v 2.01 © NCH Swift Sound

- o]

[] copy folder structure of source

[ Output to same folder as source files

|
Convert

files

14. We now need to set some preferences.

Set the Output Format to RAW and the Encoder Options as shown below. For the Format option, flip between G711

alaw or G711 ulaw.

B Switch Sound File Converter

Switch Sound File

smror (1 <] et oo | |

SIEEE]
File Convert Edit Help
AddFile(s) Add Folder Ferove  Rernove 4 Options ToolBox ‘ Help
List of files to convert Farmat Fomat G71lalaw hd
Add Files to Convert into this Iff Sample 2000 = | Jonjour keyboard.

Grarmes

[ ok [ cencel |[ hHep |
Cutput folder TS fdickey\Desktop folder as source files

ift Sound

e
Open Output Falder | [] Copy folder structure of source files

|
Convert

15. Add the files (click on the large green + sign) and click on the convert button
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@ SANGOMA

B Switch Sound File Converter

[E=8Ee >3
Edit  Help
< Add File(s) Add Eafider Remove All Optlc:ns | Convrg | Upgrade  ToolBox Help
izt o TIes to convert Format Size Conta... Extended Information
Germany_Busy_Tone Wav 0,029 CilUs,.. Codec: Microsoft PCM Format

Outputfolder  C:\Users\fdickey'Desktop'Tones

Output Format Encoder Options...

1 items, 0 items currently selected

- 7] Output to same folder as source fies
Open Output Folder [ Copy folder structure of source files

16. Rename your files according to the list provided above [in this example tone_72_alaw.raw (for busy tone)] and copy
it in the NetBorder Express > Gateway > Tone folder. (you may want to make copies of the existing files first)

17. You will need to repeat this process for all the WAV files you have previously created.
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Appendix A

How do | use Audacity for tones that require 2 or more frequencies at the same
time?

Some countries have tones that have multiple frequencies playing at the same time. For example, in the UK, the Ringing
Tone is defined as: [400Hz+450Hz] on for 0.4 sec, OFF for 0.2 sec, [400Hz+450Hz] on for 0.4 sec, OFF for 2.0 sec
To do this in Audacity, you need to work with 2 separate tracks that are merged when saving the project file.

Let’s see how.

1. Open Audacity and add two audio tracks from the Project Menu:

3 Audacity f=lbe s
File FEdit View [Project | Generate Effect Analyze Help
: = HAE T
I =7 ?ﬂportfu:\‘o‘.‘ Ctrl+I R Tl
: p‘H * mport Labes... Sd)my 45 3630241812 6 0 S 45 3630 241812 6 (
1o Import MIDL... 0 10 50 6.0 7.0 8.0 9.0
| Import Raw Data... L - - - L -
X| Audio Track ¥ =
Mono, 8000Hz Edit ID3 Tags...
16-bit

= T3 Quick Mix
L@ New Audio Track b

R New Stereo Track
New Label Track

%] Audio Track ¥ M Ty Tred

Mono, 8000Hz

i Remove Tracks
Mute | Solo
- + Align Tracks... 3
[ c WA
Align and meve cursor... S
L W
Add Label At Selection Ctrl+B
- Add Label At Playback Position Ctrl+M -
] L4
Project rate: 8000 |Cursur: 0:00.232200 min:sec [Snap-To Off]

A

2. Let’s now work on the first track for the 400Hz frequency by adding the proper tones and silences with the right
intervals:

3 Audacity [f=rliE s

File Edit View Project Generate Effect Analyze Help

EIT_Z’ J W) k) ®),n [ ] W
p‘._. k ry s J r S)my 45 3630 241812 6 0 S 45 36 30 241812 6 (
-0.5 1.'5 2|.|) 2|.5 }.0

X[ Audio Track ¥ ] 1.l =

Mono, 8000Hz
16-bit
Mute Solo

+

TH.@.....
Logl R

[T T
ZIR[ IR[

%[ Audio Track ¥
Wono, 3000Hz
16-bit

Mute | Solo
= +

Click and drag to select audio

Project rate: 8000 |Cursur: 0:00.154440 min:sec [Snap-To Off]
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3. Let’s now work on the other frequency of 450Hz, on the other Audio Track:

) Audacity
File Edit View Project Generate Effect Analyze Help

= e ]

JI=¢ (L] Tol

L] ] 1 B | R

0] e el e el el

1:)\z| 45 36-30 2418 12 6 0 ﬁ -45

36 -30 24 18 12 6 (

-0.5 l 0.5 1.0 1.5 20

2.

5 3.0

h
X | Audio Track ¥

Mono, 8000Hz

X | Audio Track ¥

Wono, B000HZ
16-bit

Mute Solo
- +

Click and drag to select audio

Project rate: 3000 |cursor: 0:01.243243 min'sec [Snap-To 01

4. We need to adjust the volume so as not to go above -12dB. Slide the volume meters on both tracks equally. In
this case, we moved the slides down to approximately -18dB each to get a combined mixed signal that does not

go above -12dB:

) Audacity
File Edit View Project Generate Effect Analyze Help

= e ]

;;j!/

I I= ra
- J Wl &

ol ) o) n) =) »)

1:)\z| 45 36-30 2418 12 6 0 ﬁ -45

36 -30 24 18 12 6 (

-0.5 U 0.5 v 1.0 1.5 20

25

3.0

X | Audio Track ™

Wono, 3000Hz

X | Audio Track ¥

Wono, B000Hz
16-bit

Drag the label vertically to change the order of the tracks.

Project rate: 3000 |cursor: 0:00.181467 min:sec [Snap-To O]
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5. You are now ready to save the project in WAV format. Go to the File menu and select Export as WAV...

Audacity will prompt you to that your tracks will be mixed to as single mono channel. Click OK and save your

WAV file.
& Audacity [=E=]
File FEdit View Project Generate Effect Analyze Help
= e : A 5]
E = > [ ] n ] ] A 18]
: p‘H 5k .y 7 s s " Ay 45 3630 241842 650 P 45 3630 2418412 6 (
5

X| Audio Track ¥

Mono, 8000Hz

X | Audio Track ¥

Mono, 8000Hz

1.5 2.0

2.5 3.0

=

-

Warning

Your tracks will be mixed down to a single meno channel in the exported file
[~ Dont show this waming again

Project rate: 8000 |Cursur: 0:00.181467 min:sec [Snap-To Off]

6. To convert to RAW format, proceed as explained earlier in this document.
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