NetBorder Express

@ SANGOMA Tone Detection and Generation

Configuration Guide

Overview

This guide will show you how to configure tones for your NetBorder Express gateway. There is a great variety
of tones from country to country and NetBorder Express needs to be configured accordingly.

You will find that this guide has several pages but this does not mean it is a highly complex process. Rather,
we have included several screenshots to guide you through the process.

There are two broad functions in the gateway regarding tones in NetBorder Express: Tone Detection and
Tone Generation.

For Tone Detection, the NetBorder Express Gateway uses tone definition files. These are in XML form. All
you need to adjust the tone definitions is to edit the file with a text editor or within the NetBorder Express
Gateway Manager Web GUI. This guide will provide you with detailed examples using the NetBorder Express
Gateway Manager Web GUI. To illustrate further, we will use Germany settings, as an example.

For Tone Generation, the NetBorder Express Gateway plays sound files in a RAW format. What you need to
do to adjust Tone Generation for NetBorder Express is to use an Audio Editor application to generate the
RAW files. This guide will provide you with ample details using screenshots from free applications.

Version 2.x of NetBorder Express is pre-configured for North American tone sets. So you do not need to
perform these steps if your installation is within North America (USA and Canada).

For DTMF tones, NetBorder Express default installation is universal, so you do not have to adjust anything.
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Tools and pre-Requisites

1. Pre-Installed version of NetBorder Express
2. Access to a Tone Definitions database. Here are some useful links:

. http://www.itu.int/dms pub/itu-t/oth/02/06/T02060000040002PDFE.pdf

. http://www.3amsystems.com/wireline/tone-search.htm

3. Pre installed Audio Editors. Here you will need 2 applications: Audacity and NCH Audio Switch. These
are free applications.

« To create WAV files, Audacity is required. You can get it here:

http://audacity.sourceforge.net/download/. At the time of this writing, version 1.2.6 was used.

» NCH Audio Switch is required to convert the WAV files into RAW format. You can get it here:

http://www.nch.com.au/switch/ . At the time of this writing, version 2.01 was used.

Let’s get started!


http://www.itu.int/dms_pub/itu-t/oth/02/06/T02060000040002PDFE.pdf
http://www.nch.com.au/switch/
http://audacity.sourceforge.net/download/
http://www.3amsystems.com/wireline/tone-search.htm
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Configuring Tone Detection

This step requires the editing of the tone definition XML files. Here we will use Germany as an example.

1. Launch the NetBorder Gateway Manager Utility (here on the localhost:7783) and point it to the File
Browser sub menu and then to the config and then tone-def subfolder. Scroll down to Germany and
click once on the file name. The XML file is now ready to be edited.

@ Gateway Manager - Mozilla Firefox El@
File Edit View History Bookmarks Tools Help
? C 4y ([ | nttp/ntocalhost7783/ < - el

NetBorder®
BEXPRESS VolP Gateway @ SANGOMA

Status and Controls Configuration Quick Setup File Browser || Help

=3 roat » | This section of the webUl allows you to read and edit configuration and logging files. Grayed out file name in the tree
& £ bin means a read only files. It is possible to download files by right-clicking on a file in the tree panel.
=43 config

2 S tone-def File: /root/config/tone-def/germany.xml
= <?yml version="1.0" encoding="utf-8"?> -

@) argentina. xmi 1 et name="GERMANY" version="1.0">
&4 australia.xml

€ austria.xml <! Tone definitions
4| bahrain.xml —

m

& beli A A tone is defined as sequence of signals where each signal (si) last
3| elglum.xm for a spedfied duration in second (di).

& brazilxml

| bulgaria xml Example A: |

£ canada.xml

& chile.xml
€| china.xml In this example tone is defined by a signal s1 that will last for a
duration d1, folowed by a signal s2 that will last for duration d2,

&4 columbia.xml
followed by a signal s3 that will last for duration d3.

#4| croatia.xml

& cyprus.xml The signal could be:

@/ czech.xml - off: no signal

- f1: a single frequency

- - f14£2: juxtaposition of two frequencies f1 and 2 without modulation.

| ecuador.xml - f1+f2+f3: juxtaposttion of tree frequencies 1, f2 and f3 without

4 egyptxml modulation.

- flxf2: f1 is modulated by f2 *** NOT SUPPORTED IN THIS VERSION ***

&4 denmark.xml

& elsatvador.xml

@) fecami vhere all fi are specfied in Hz.

# finland.xml

& france.xml A sequence or subset of the sequence could be repeated few times.
n

&4 germany.xml
& greece.xml

T o . Save Changes ] [ Clear Changes

e
subsequence between parathisis and specifv the number of

Gateway Status: stopped Configuration Synched @

Done




@ SANGOMA

2. You need first to datafill tone definitions and then assign them to Tone Detection Rules.

You need at this point the tone definitions for Germany. These are:

e Busy Tone: 425 Hz for 0.48 sec, OFF for 0.48 sec, repeat

e Reorder Tone / Congestion Tone: 425 Hz for 0.24 sec, OFF for 0.24 sec, repeat

» Dial Tone: 425 Hz Continuous

» Ringing Tone: 425 Hz for 1.0 sec, OFF for 4.0 sec, repeat

 Call Waiting: 425 Hz for 0.2 sec, OFF for 0.2 sec, 425 Hz for 0.2 sec, OFF for 5.0 sec, repeat
e SIT Tone: 950 Hz for 0.33 sec, 1400 Hz for 0.33 sec, 1800 Hz for 0.33 sec, OFF for 1.0 sec,
repeat

Here is the germany.xml file updated with the German specifications:

@ Gateway Manager - Mozilla Firefox
File Edit View History Bookmarks

e X & O
NetBorder"

Tools Help

http://lecalhost 7783/

EXPRESS VoIP Gateway

Status and Controls Configuration

=) root
& (] bin
=) config
= tone-def
&4 argentina.=xml
# australia xml
4| austria.xml
4| bahrain.xml
#4) belgium.xml
€ brazil.xml
€4 bulgaria.xml
£ canada.xml
£ chile.xml
€ china.xml
4| columbia.xml
4| croatia.xml
&4 cyprus.xml
# czech.xml
4| denmark xml
& ecuador.xml
&4 egypt.xml
# elsalvador.xml
8 feoxml
&/ finland xml
& france.xml
¥ germany.xmi
£ greece.xml

4 I

Gateway Status: stopped

[(=EEE

@ SANGOMA

Quick Setup File Browser || Help

» | This section of the webUI allows you to read and edit configuration and logging files. Grayed out file name in the tree
means a read only files. It is possible to download files by right-clicking on a file in the tree panel.

File: jroot/config/tone-def/germany.xml
The user may create as many tone he needs in this section. The name
of the tone is not important, as long as the name is unique within
tones context of this tone set. The name is used as a unigue key to
identify a given tone definition. The tone detection and generation
rule are referencing a tone definition by using that key.

m

<tone name="busy">2%(425/0.48, off/0.48) periodic</tone>

<tone name="congestion">=2*(425/0.24, off/0.24) periodic</tone>

<tone name="dial">425/continuous<,/tone>

<tone name="dial_start">425/2.0</tonex>

<tone name="specil_dial">425+400/continuous</tone>

<tone name="specil_dial_start">425+400/1.0</tone>

<tone name="ringing">425/1.0, off/4.0 periodic</tone>

<tone name="specil_information"=950,/0.33, 1400/0.33, 1800/0.33, off/1.0 periodic=</tone>
</tones=|

m

<! Tone detection rules

This section tels which tone definition(s) to use for each type of
tone required by the gateway. For each type of tones, the user may
specify one or more tone definitions. Each tone definition shall be
country the application has to recognize 3 types of busy tone

(busyl, busy2 and busy3) the user shall enter the busy detection
rule as follow: <busy=busyl|busy2|busy3</busy=>

'

[ Save Changes I [ Clear Changes

Configuration Synched @

Done
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3. Next Step is to edit the Detection Rules in the same file (scroll down). Here is the updated file for
our Germany example. Do not forget to click on the Save Changes button!

@ Gateway Manager - Mozilla Firefox El@
File Edit View History Bookmarks Tools Help
- £ ([ | nttpntocalhost7783/ 77 - ]

NetBorder’
EXPRESS VolP Gateway

Status and Controls || Configuration || Quick Setup File Browser | Help

@ SANGOMA

=3 roat + | This section of the webUl allows you to read and edit configuration and logging files. Grayed out file name in the tree
& - bin means a read only files. It is possible to download files by right-clicking on a file in the tree panel.
=43 config _ §
=53 tone def File: /root/config/tone-def/germany.xml

& argentina.xmi =|| tone required by the gateway. For each type of tones, the user may -
- g o specify one or more tone definitions. Each tone definition shall be
) australia xml delimited by the pipe ('|') caracter. For example: If in a given
| austria.xml country the application has to recognize 3 types of busy tone|
& bahrain.xmi | (busyl, busy2 and busy3) the user shall enter the busy detection

& beigumxmi rule as follow: <busy=busy1|busy2|busy3</busy>

& brazilxml —=

| bulgaria.xml <detection_rules>

&4 canada.xml <bu5v>busv<,l'bu5'_,r>

- <reorder=congestion</reorder>

) chile.xml <dial=dial|special_dil</dial>

| china.xml <dial_start>dial_start|special_dial_start</dial_start>
&/ columbia.xml <ringing=ringing</ringing=

<sit=specal_information</sit>
<disconnect></disconnect>

# cyprus.xml </detection_rules>

# czech.xml

& croatia.xml

<l Tone generation rules

& denmark.xml www NOTICE ***

B8 ccuadorxmi This section is not used in this version

# egypt.xml _
& elsalvador.xml This section tels which tone definition(s) to use for each type of

@ feexml tone that could be generated by the gateway. For each type of

tones, the user shall specify only one tone definition.
& finland.xml

# france.xml - " |

SN s> busv<bus .
. |$' > Save Changes ] [ Clear Changes
Gateway Status: stopped Configuration Synched

Done




Configuring Tone Generation
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For Tone Generation, you will have to generate 8 RAW files with a sound editor. These files will have to be

named in a specific way and copied in the proper folder, as shown in the picture below. It looks like they

have a funny naming convention, but they really refer to tone IDs defined by the IETF RFC2833 (RTP Payload

for DTMF Digits, Telephony Tones and Telephony Signals). A-Law and u-Law refer to different companding

algorithms. In general terms, u-law is in use in North America and A-law is used in the rest of the world. The
files are located under the data and tone-waves folders.

tone_70_alaw = Ringing Tone
tone_70_ulaw = Ringing Tone
tone_72_alaw = Busy Tone
tone_72_ulaw = Busy Tone
tone_73_alaw = Congestion Tone
tone_73_ulaw = Congestion Tone

tone_74_alaw = Special Information Tone

tone_74_alaw = Special Information Tone

@\J'l « Netborder + Express b Gateway » dota b toncwaves

File Edit View Tools Help
Wy Organize

- |‘9‘ ‘ Search

Views ~ (M Open 7

Name Date modified Type Size

|| tone 8 ulaw 11/3/20001229PM  RAW File 16 KE
fokder) [Jtone 9_alaw 11/9/200912:29 P RAW File 16 KB
Mozilla Firefox “ | | ]tone 9_ulaw 11/8/200912:29 PM  RAW File 16 KB
MSBuild || tone_10_alaw 11/9/200912:20 PM  RAW File 16 KB
MSECache __|tone 10_ulaw 11/9/200912:29 P RAW File 16 KB
MSXML 4.0 | |tone 11_alaw 11/8/200912:29 PM  RAW File 16 KB
MultiScreen | |tone11_ulaw 11/9/200912:29 PM  RAW File 16 KB
NCH Software _|tone 12_alaw 11/9/200912:29PM  RAW File 16 KB
4} Netborder [ |tone 12_ulaw 11/9/200912:29 PM  RAW File 16 KB
4 | Bxpress | Jtone_13_alaw 11/3/200912:29PM  RAW File 16KB
4 | Gateway |_Jtone_13_ulaw 11/3/200012:29PM  RAW File 16KE
. bin || Ultone 14 alaw 11/9/200012:29 PM  RAW File 16KE
config || [tone14_ulaw 11/8/200912:29 PM  RAW File 16 KB
4 ) data | Jtone_15_alaw 11/9/20091229PM  RAW File 16 KE
Pythen-2.5 __|tone 15_ulaw 11/9/200912:29 PM  RAW File 16 KB
scripts || tone 70_alaw 11/8/200912:29 PM  RAW File 47KB
templates || tone_70_ulaw 11/9/200912:29 PM  RAW File 47KB
tone-waves __|tone_72_alaw 11/9/200012:29PM  RAW File B/EKE
4 i doc __|tone 72_ulaw 11/9/200912:29 PM RAW File /KB
1 open-source-license |_|tone_73_alaw 11/9/200912:29 PM  RAW File 32KB
s ace || tone_73_ulaw 11/9/20091229PM  RAW File 2KE
- asnle __|tone 74 alaw 11/9/200912:29PM  RAW File 32KE
boost tone 74 iaw 1179/300312:59 PM_ RAW File 37K8

! db -

il

The RAW files that are pre-installed correspond to North American tones. So for our Germany example, we
will need to create new ones. For this, we will use Audacity.

1. Launch the Audacity application. It should look as follows:
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Edit View Project Generate Effect Analyze Help

L] TL]
R| | R

W) o7 48 42 36 30 24 18 12 6 0 )Izl 48 42 .36 -30 -24 16 12 6 |

el W) e)u) )

S| o] plp28)
-1.0 00 1.0 2.0

3.0 4.0 5.0 6.0 7.0 8.0 9.0

4 3

Project rate: 8000 | cursor: 0:00.000000 min:sec [Snap-To O P
A
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2. We now need to edit preferences of the software. Go to the Edit menu and select Preferences...

Select the Quality tab. Set Sample Rate at 8000 Hz and the Default Sample Format at 16 bit as follows:

Jot | @] o{ i s e [Fw
10 oo

Default Sample Format: | 16-bit hd

High-qualty sample rat

Realtime sample rate converter: | Fast Sinc intempolation hd

Realtime dither:  |None -
Highqualty dther: [None =

High-qualty Sinc Interp -

& tudacity [=r=E]=]
File Edit View Project Generate Effect Analyze Help
=
=7
: “) >
BPSIEadR 3 Audio 0 Qualty | File Fommts | Spectrograms | Directories | Interface | Keyboard | Mouse |

(48 42 .36 30 .24 18 12 6 |

Project rate: 8000 |Curmr:0mm min:sec [Snap-To Off]

Under the File Formats tab, set the Uncompressed Export Format to WAV (Microsoft 16 bit PCM) as

follows:

& tudacity [=r=E]=]
File Edit View Project Generate Effect Analyze Help
<
= ¢
: “) >
SR ek J Audio /O | Qualty  Flle Formats. |Sped.mgrams| Dirsctories | Interface | Keyboard | Mouse |

audio files into Audacity

Jot [ ma @[] o[ whenimeonng
10 o0 " Make a copy of the file before edting (safer)
£ @ Read directly from the original file Faster)

Ur Export Format

MP3 Library Version: MP3 exporting plugin not found

Bit Rate: 128 ~

(48 42 .36 30 .24 18 12 6 |

Project rate: 8000 |Curmr:0mm min:sec [Snap-To Off]
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Under the Interface tab, unselect the Edit and Mixer Toolbar options as follows:

EIEEE]

& Audacity
File Edit View Project Generate Effect Analyze Help
AT =g
: =
E o |
1oy 5/ 2
HICD I @
1. [V Autoscroll while playing

™ Aways allow pausing

I~ Aways allow playing

¥ Update spectrogram while playing

I™ Erable Edit Toolbar

I~ Enable Mixer Toolbar

¥ Enable Meter Toolbar

¥ Quit Audacty upon closing last window

Language: |Engish -

[L

W Enable dragaing of left and right selection edges
I™ Enable ergonomic onder of Audio 140 buttons

Audo 0 | Qualky | Fie Formats | Spectrograms | Directories ~ Intefface | Keyboard | Mouse |

45 36 24

12 61

Minimum of dB mode display rangs

48 dB (PCM range of 8 bit samples)
36 dE (PCM range of 16 bit samples)

" 145 dB (PCM range of 24 bit samples)

@ -36 dB shallow range for high-ampltude ediing)

' -120dB (spproimate limit of human hearing)

4

Cancel

Froject rate: 8000 |cursor: 0:00.000000 min:sec [Snap-To 0ff

3. We are now ready to start editing a sound file. Let’s start with the Germany Busy Tone, which is

defined as

425 Hz for 0.48 sec, OFF for 0.48 sec.

Go to Project > New Audio Track

File Edit View Project Generate Effect Analyze Help

JIOIUIIIIf

HN
AL
5"’\2 45 36 -30 24

[
IRl

12 6 0 /@EI -45 36 -30 24

12 6 (

o Play (Shift for loop-play) 3"0

4.0 5.0

6.0

7.0 8.0 9.0

| Audio Track ™ | 1.0
Mono, 8000Hz

16-bit 05
Mute | Sob | | g0
B .

L R =5
S0 e

4]

N

[Pay (Shift for loop-play)

Project rate: 8000 |cursor: 0:00.000000 min'sec [Snap-To Off]
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4. Go to Generate > Tone. Enter the frequency and duration in seconds (here 425Hz for 0.48 sec.) and
click Generate Tone.

€3 Audacity EEE]

File Edit View Project Generate Effect Analyze Help

Hhral - I;I

: | | 3 @ n | Tone Generator ==

| 2le]x S S 4F &) 74 A2 5 0 Bz 45 363024 A2 5
1.0 00 1.0 20 Wavefom: | Sine =l 6.0 7.0 80 q.i.

Froquency /Hz [425
Ampltude @1) [100
Length econds) 28

=

4

Project rate: 8000 |Cursur: 0:00.000000 min:sec [Snap-To Off] V)
A
) Audacity =0T |

File Edit View Project Generate Effect Analyze Help

T = g [l
: = : I'R[

ey 45 -36-30 -4 12 6 0 ﬁlil -45 .36 -30 -24 A2 6 o

4]

Project rate: 8000 |5¢e>ecmn: '0:00.000000 - 0:00.480000 (0:00.430000 min:sec) [Snap-To Off] y
A

5. Go to Edit > Move Cursor > to Track End to position you cursor at the end of the track.

6. Go to Generate > Silence. Insert a silence for 0.48 sec.
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aAuda:rty \EI@

File Edit View Project Generate FEffect Analyze Help

HE I
[ /|

Bl sl »Ij Sy 45 363024 12 60 P 45 3630 4 A2 b
0.05 0.10 0.15 .20 0.25 3 035 0.40 0.45

-

.

w“«'rUH o roWHw\ |

I

Project rate: 8000 |Cursur: 0:00.480000 min:sec [Snap-To Off]

A
&) audacity (F=1[FCR ||
File Edit View Project Generate Effect Analyze Help
B 5 HN [l
= nm) m) M o I8
;p|H * / / / v tar / g 45 304 4260 S 45 363024 A2 5 (
. 0.10 020 0.40

T

I “I"I“' H
.“WWNWWN%JWMWHMM

Click and drag to select audio

T
hmmmMﬂ

Project rate: 8000 | setection: 0:00.480000 - 0:00.960000 (0:00.430000 min'sec) [Snap-To Off]

7. Repeat the process so that you have at least 2 cycles. You track should look now as follows:

£ Audacity = EoR =
File Edit View Project Generate Effect Analyze Help

B - N [l

i é n) m) w [l IR

;p|ﬂ* " J / / S | U 45 3b30M 1260 Sy 45 363024 12 5
010 0.00 010 020 03§ 040 0.50 060 0.70 080 00 1.00 110 120 130 140 150 160 170 1.80 180 |7

Click and drag to select audio

Project rate: 8000 |Cursur: 0:00.327865 min:sec [Snap-To Off]

8. Now you can listen to the track for verification and to check the volume. Hold the shift key and click
on the play button for loopback playing. It sounds like a Busy Tone!

£ Audacity (=i s

File Edit View Project Generate Effect Analyze Help

4T = Li L

: = 1 ’/e; ®) n) m) » I I |

5p|ﬂ* J I\ | sy 45 36304 1260 Sy 45 363024 A2 5
20 010 0.00 0.9 0.20 0.0 040 050 0.60 0.7

0.80 0.90 1.08 110 1.20 1.30 1.40 1.50 1.60 1.70 1.80 190.

[Play (shift for loop-play)

Project rate: 8000 |Cursur: 0:00.327865 min:sec [Snap-To Off]
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9. However, the volume is too loud (green bars on the meter toolbar).
As a rule of thumb, you should stay below -12 dB.

While the track is playing in loopback, slide the volume to the left to lower the volume.

£ Audacity (=i s

File Edit View Project Generate Effect Analyze Help

Iri= s 7 ;Lj I

: = wiley @) n = W B ] IR

;p|ﬂ sk J J J | S| ey 45 3B30M 4250 S 45 363024 12 6 (
0.10 0.00 0.10 020 030 0.40 0.50 0.60 0.70 080 0.90 1.00 1.10 T20 1.30 1.40 150 1.60 1.70 1.80 1.|9o.

Drag the label vertically to change the order of the tracks.
Project rate: 8000 |Cursur: 0:00.327265 min:sec [Snap-To Off]




10. Now we are ready to save our file. Go
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to File > Export as WAV and save your file

» [& Control Panel
'€ Recycle Bin

& L) TDM_Gateway_User_Guide
.. Tones

& Audacity [=ErEE]
File Edit View Proje 3 Save WAV (Microsoft) File As: @
: I_Z.— ] G(Dvl“ » Tones v“’ll.&‘eam‘) A
: b
g }5|H *k Bl Wy Organize G | 45 -36 -30 -24 12 6 (
0.30 -0.20 -0.10 0. T Name. Artists Album & - 1.60 1.70 1.80 1.90
EI Da—. @ Germany_SIT_Tone
" [ UK Ringing_Tone
ore »
Folders hd
“““ » B fdickey -
“““ & Public
& /% Computer
b ¥ Netwark

File name: Germany_Busy Tone

Save as type: | WAV (Microsoft) files (".wav)

2]

+' Hide Folders

—

Project rate: 2000 ‘ |E

Eave Cancel

11. Repeat this process for all your tones. Once you have the WAV files for all your tones, you are ready

to produce the RAW files.

12. We are now ready to generate the RAW files using NCH Audio Converter.

13. Open NCH Audio Converter.

I Switch Sound File Converter

s (E=E|Fo(Fx5)
File Convert Edit Help
AddFiles) AddFolder Fcrmove  Fernowe 21 Options Play Stop Convert Upgrade  ToolBex ‘ Help
List of files to convert Format Size: N Conta... Extended Information
Add Files to Convert into this list by dlicking the "Add Files™ button or pressing Alt-+A on your keyboard.
Output folder  ¢:\Jsersfeickey DesktopTones - 7] Gutput to same folder as source fies >y
Output Format Encoder Options... | Open Output Faolder [] Copy folder structure of source files Convert
Switch Sound File Converter v 2.01 © NCH Swift Sound

14. We now need to set some preferences.

Set the Output Format to RAW and the Encoder Options as shown below. For the Format option, flip

between G711 aLaw or G711 ulaw.

H Switch Sound File Converter
File Convert Edit Help

X e

AddFile(s) AddFolder Fernove  Rernove Al Options

List of files to convert Format

Add Files to Convert into this i

= [=]re=
~ - w Y
oo il =] B Help
Format G711 alaw -
Sample 3000 * | bon vour keyboard.
Channels

(

OK | [ Cancel ][ Heb

Output folder  C:\Users\fdickey\DesktopiTones

folder as source files

ot et |

Switch Sound File Converter v 2.01 © NCH Swift Sound

Convert

e
Open Output Folder | [ Copy folder structure of source files
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15. Add the files (click on the large green + sign) and click on the convert button

B Switch Sound File Converter o= =)
File Convert Edit Help

Add File(s) Add Folder Remove Al Options | Convret | Upgrade  ToolBax Help

List of files to convert Format Size Conta... Extended Information

Germany_Busy_Tone v 0.029 C:\Us... Codec: Microsoft PCM Format

Output folder  C:\Users\fdickey\Desktop{Tones

- [T] output to same folder as source files %:j
Output Farmat Encader Opions... Open Output Folder ] Copy folder structure of source files Convert

1 items, 0 items currently selected

16. Rename your files according to the list provided above [in this example tone_72_alaw.raw (for busy

tone)] and copy it in the NetBorder Express > Gateway > data > tone-wav folder. (you may want to
make copies of the existing files first)

17. You will need to repeat this process for all the WAV files you have previously created.
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Appendix A

How do | use Audacity for tones that require 2 or more frequencies at
the same time?

Some countries have tones that have multiple frequencies playing at the same time. For example, in the UK,

the Ringing Tone is defined as: [400Hz+450Hz] on for 0.4 sec, OFF for 0.2 sec, [400Hz+450Hz] on for 0.4 sec,
OFF for 2.0 sec

To do this in Audacity, you need to work with 2 separate tracks that are merged when saving the project
file.

Let’s see how.

1. Open Audacity and add two audio tracks from the Project Menu:

£ Audacity

= e
File Edit View Generate Effect Analyze Help
T —Z—' & Import Audio... Ctrl+I IF‘{} ;I
2ok preits W 46 3630 241812 5 0 S 45 36-30 2418 12 5 (
10 Import MIDL.. 0 10 50 6.0 7.0 80 90
f———] Import Raw Data... L : L L : :
%[ Audio Track ¥ =
Mono, 8000Hz Edit ID3 Tags...
16-bit
Wute | Solo Quick Mix
e New Audio Track L
L 2] R New Stereo Track
New Label Track
M New Time Track
Mono, 8000Hz
16-bit Remaove Tracks
Wute | Solo
+ Align Tracks... 3
@
Align and move cursor... 3
L O R
Add Label At Selection Ctrl+B
Add Label At Playback Position Ctrl+M -
. [
Project rate: 6000 Cursor: 0:00.232200 min:sec [Snap-To Dff]

2. Let’s now work on the first track for the 400Hz frequency by adding the proper tones and silences
with the right intervals:
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) Audacity [E=R(ESH =
File Edit View Project Generate Effect Analyze Help

Nl Ia ol

: W)r)e)n)m)mwm A 7l

g }D‘H *k r . v 7 7 F “)E 45 36-30 -24-18 12 6 0 }El -45 36 -30 24 -18 12 6 (

-0.5

1.5 2.0 2.5 3.0

X | Audio Track ¥

Wono, 3000Hz

X | Audio Track ¥

Mono, 8000Hz

16-bit

Mute Solo
- +

Click and drag to select audio

Project rate: 5000 |Cursnr: 0:00.154440 min:sec [Snap-To Off]

A
3. Let’s now work on the other frequency of 450Hz, on the other Audio Track:
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4. We need to adjust the volume so as not to go above -12dB. Slide the volume meters on both tracks
equally. In this case, we moved the slides down to approximately -18dB each to get a combined

mixed signal that does not go above -12dB:



@ SANGOMA
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Drag the label vertically to change the order of the tracks.
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@ SANGOMA

5. You are now ready to save the project in WAV format. Go to the File menu and select Export as

WAV...

Audacity will prompt you to that your tracks will be mixed to as single mono channel. Click OK and

save your WAV file.
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6. To convert to RAW format, proceed as explained earlier in this document.
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